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1. Introduction 

Thank you for purchasing Wordman’s Hiliter. 

Wordman’s Hiliter, an add-in for Microsoft Word, provides a tool for easily 
highlighting multiple words and phrases (“keywords”) in a proposal doc-
ument, based on a custom list that you can share throughout your pro-
posal team. This add-in can help to ensure compliance with official pro-
posal terms, and to avoid accidental previous client names from being 
included when reusing content. 

You can create and manage multiple keyword files and share them with 
other members of your proposal team. Each keyword can have different 
search options, e.g., only matching the whole word rather than the key-
word embedded in other words, and a different highlight color. 
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2. Installation 

Wordman’s Hiliter is supplied in a ZIP file, Wordman_Hilter.zip. Save this 
file to your PC, open the ZIP file, and extract Wordman Hiliter.dotm to the 
special folder that Microsoft Word uses to store add-ins. 

To do this, first open Windows Explorer by pressing the Windows button, 
, and E together. In the address box, type %appdata% and then press 

Enter: 

 

Windows Explorer displays the contents of your personal AppData/ 
Roaming folder. Open the Microsoft folder, and in that folder, open the 
Word folder. In the Word folder, open the STARTUP folder. Save the 
Wordman Hiliter.dotm into the STARTUP folder. 

You will see Windows has expanded %appdata% to the full path, e.g. 

C:\users\[username]\appdata\roaming\microsoft\word\STARTUP 

where [username] is your username on your PC. 
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3. Licensing 

Wordman’s Hiliter is a licensed product. After you have installed and first 
run Wordman’s Hiliter, a thirty-day evaluation period starts, allowing full 
functionality. After the thirty-day evaluation period expires, you need to 
purchase a full license to continue using Wordman’s Hiliter. To enter a full 
license key, click  About in the Abbreviations group on the Wordman 
ribbon tab: 

 

On the About Wordman’s Hiliter dialog, click Enter Key. Wordman’s Hiliter 
displays the Wordman’s Hiliter License dialog: 

 

Enter the Username and Key you received by email from Wordman 
Speaks when you purchased your Wordman’s Hiliter license. 
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4. Using Wordman’s Hiliter 

4.1. Displaying the Hiliter Dialog 

To display the main Wordman’s Hiliter dialog, click  Hiliter in the Hiliter 
group on the Wordman ribbon tab: 

 

When you first run Wordman’s Hiliter, it will start with a new keyword file, 
i.e., there will be no keyword entries. Once you have created and saved at 
least one keyword file, it will load the last used keyword file (if available) 
when it starts. 

• Keyword file displays the filename of the current keyword file, next 

to  File and  Save/Save As buttons. 

• Keywords and Phrases displays keywords, selected colors, and 
match options. 

• Edit selected Keyword or Phrase: A group of buttons—  Add, 

 Edit, and  Delete —allow you to edit keywords. 

• Run-time Options: Select to save the date and time that you ran 
Wordman’s Hiliter on the active document, the filename of the 
keyword file, and the date that the keyword file was last saved. See 
4.5, Run-time Options. 

•  Clear All clears all highlighted text in the active document 

•  Check… displays whether Wordman’s Hiliter has been run on the 
active document, and if so, when and using which keyword file. See 
4.5, Run-time Options. (Note: this is dependent on Save run date and 
file name in Document Properties having been previously checked.) 

•  Go… highlights text in the active document using the keyword 
settings. See 4.6, Highlighting Keywords in Your Document. 
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4.2. Adding or Editing a Keyword or Phrase 

To add your first keyword, or to edit an existing keyword, click  Add, or 

select the keyword and then click  Edit, to display the Add/Edit Key-
word dialog: 

 

Type the keyword in the text box under Keyword or phrase, e.g., if you are 
reusing proposal content, you could type the name of a previous client. 
There are nine Match options that you can use to modify the keyword 
search: 

• Match case: When checked, highlights only words or phrases that 
have the same case as the keyword. 

• Whole words only: When checked, highlights words such as “word” 
but not “Wordman”. Non-alphabetic characters in the keyword box 
disables Whole words only. 

• Match prefix: When checked, highlights words beginning with the 
keyword. 

• Match suffix: When checked, highlights words ending with the key-
word. 

• Use wildcards: When checked, only highlights the exact keyword: 
see 4.2.3, Using Wildcards. Checking Use wildcards disables Match 
case, Whole words only, Match prefix, and Match suffix, and 
unchecks Sounds like, and All word forms (if checked). 
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• Sounds like: When checked, highlights homonyms, or words that 
sound the same as the search word, e.g. “their” and “there,” “deer” 
and “dear,” or “hear” and “here.” Checking Sounds Like disables 
Match case, Whole words only, Match prefix, and Match suffix, and 
unchecks All word forms (if checked). 

• All word forms: When checked, highlights all variations of a word, 
e.g., if the keyword is “walk,” also highlights “walking” and “walked.” 
Checking All word forms disables Match case, Whole words only, 
Match prefix, and Match suffix, and unchecks Use wildcards and 
Sounds like (if checked). 

• Ignore punctuation: When checked, highlights text that is similar to 
the keyword, but contains punctuation within it. For example, if the 
keyword is “recreated,” Wordman’s Hiliter also highlights “re-
created.” 

• Ignore white-space: When checked, highlights text that is similar to 
the keyword, but may contain spaces. For example, if the keyword is 
“Wordman,” Wordman’s Hiliter highlights “Word Man.” 

The table below summarizes the combinations of Match options: 
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Case  ✓ ✓ ✓    ✓ ✓ 

Whole word ✓  ✓ ✓    ✓ ✓ 

Ignore punctuation ✓ ✓  ✓ ✓ ✓ ✓ ✓ ✓ 

Ignore white-space ✓ ✓ ✓  ✓ ✓ ✓ ✓ ✓ 

All word forms   ✓ ✓      

Use wildcards   ✓ ✓      

Sounds like   ✓ ✓      

Match prefix ✓ ✓ ✓ ✓     ✓ 

Match suffix ✓ ✓ ✓ ✓    ✓  
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4.2.1. Inserting Special Characters 

Special characters include em dashes and non-breaking hyphens, and 
simple wildcards such as Any Digit and Any Character. To insert a spe-
cial character in your keyword, click Insert Special Characters…, and then 
select the special character from the dropdown list: 

 

Wordman’s Hiliter inserts the following codes into your keyword: 

Special Character Code  Special Character Code 

Tab Character ^t  Em Dash ^+ 

Any Single Character ^?  En Dash ^= 

Any Digit ^#  Non-breaking Hyphen ^~ 

Any Letter ^$  Non-breaking Space ^s 
  

 Optional Hyphen ^- 

Inserting a special character disables the Whole words only option. 

4.2.2. Selecting a Highlight Color 

Each keyword can have its own highlight color from the set of sixteen 

colors allowed by Word. To select a color, click  Highlight Color: 
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4.2.3. Using Wildcards 

(The following guidance for using wildcards is from Microsoft Word help.) 

To search for a character that is defined as a wildcard, type a backslash 
(\) before the character, e.g., type \? to find a question mark. You can use 
parentheses to group wildcard characters and text, and to indicate the 
order of evaluation, e.g., type <(pre)*(ed)> to find “presorted” and “pre-
vented.” 

To find Type Example 

Any single character ? s?t finds “sat” and “set” 

Any string of characters * s*d finds “sad” and “started” 

The beginning of a word < <(inter) finds “interesting” and 
“intercept,” but not “splintered” 

The end of a word  > (in)> finds “in” and “within,” but not 
“interesting” 

One of the specified characters [ ] w[io]n finds “win” and “won” 

Any single character in this range  [-] [r-t]ight finds “right” and “sight”. 
Ranges must be in ascending order 

Any single character except the 
characters in the range inside the 
brackets 

[!x-z] t[!a-m]ck finds “tock” and “tuck,” 
but not “tack” or “tick” 

Exactly n occurrences of the pre-
vious character or expression 

{n} fe{2}d finds “feed” but not “fed” 

At least n occurrences of the pre-
vious character or expression 

{n,} fe{1,}d finds “fed” and “feed” 

From n to m occurrences of the 
previous character or expression 

{n,m} 10{1,3} finds “10”, “100” and “1000” 

One or more occurrences of the 
previous character or expression 

@ lo@t finds “lot” and “loot” 
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4.3. Saving Your Keyword File 

Click  OK to close the Add/Edit Keyword dialog. Your keyword(s), 
options, and selected color are displayed in the table on the Wordman’s 
Hiliter dialog: 

 

To save your keyword file, click  Save As at the top of the dialog. If you 
close the Wordman’s Hiliter dialog by clicking  at the top right of the 
dialog, Wordman’s Hiliter notifies you if your keywords have not been 
saved: 

 

Wordman’s Hiliter will confirm that your file has been saved successfully: 
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4.4. Opening a Keyword File 

To open another keyword file, click  File at the top of the Wordman’s 
Hiliter dialog. Wordman’s Hiliter displays the Open Keyword File dialog: 

 

There are three methods: 

• Open a file from the list of Recent Keyword Files: click on the file you 

want to open, and then click  OK, or simply double-click on the 

file. 

• Open a file that is not on the list of Recent Keyword Files: click 

 Open and select the file from the Windows Open File dialog. 

• Create a new keyword file: click  New and Wordman’s Hiliter will 
clear the keyword list and the filename. 
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4.5. Run-time Options 

If you check Save run date/filename in Document Properties, Wordman’s 
Hiliter adds three entries to the document’s Custom Properties: 

• LastHiDate: the date and time that Wordman’s Hiliter was last run on 
this document 

• HiFileName: the filename of the keyword file that was used 

• HiFileDate: the date and time that the keyword file used was last 
modified 

To check whether Wordman’s Hiliter has been previously run on the active 

document, click  Check… on the Wordman’s Hiliter dialog. If Word-

man’s Hiliter has not been previously run on the active document, or Save 
run date/filename in Document Proprieties was not checked prior to the 
previous run, or the document properties have been deleted, Wordman’s 
Hiliter displays the following: 

 

Otherwise, Wordman’s Hiliter displays the details about the last run: 

 

Note: To view the Custom Document Properties in the Document Prop-
erties dialog, go to File > Info, and then click the arrow next to Properties. 
Click Advanced Properties: 
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Select the Custom tab on the Document Properties dialog: 

 

To remove these custom document properties prior to delivering or dis-
tributing the document, do either of the following: 

• Go to the Document Properties dialog (as described above), select, 
and then delete each of the properties, or 

• click File > Info, and then, under Inspect Document, click Check for 
Issues > Inspect Document. 

4.6. Highlighting Keywords in Your Document 

Once you have finished editing your keyword list, click  Go… on the 
main dialog. 

4.7. Clearing All Highlights 

To clear all highlighting in your document, click  Clear All on the 

Wordman’s Hiliter dialog, or click  Clear in the Hiliter group on the 
Wordman ribbon tab. 
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5. Technical Details 

5.1. Keyword (*.wmh) Files 

Keyword files have the file extension .wmh, for Wordman’s Hiliter, and are 
Extensible Markup Language (XML) files. The structure of a keyword file 
is as follows: 

<?xml version="1.0" encoding="UTF-8" ?> 
<!--(C) 2011 Dick Eassom. All Rights Reserved--> 
<Keywords> 
 <Keyword> 
  <Text>[Keyword]</Text> 
  <Options>[Options]</Options> 
  <Color>[Color Name]</Color> 
 </Keyword> 
 . 
 . 
 . 
</Keywords> 

There is a Keyword group for each word or phrase in the list. Each 
Keyword group comprises: 

<Text> the word or phrase text 

<Options> the search options, in text form, separated by commas, e.g., 
<Options>Case, Whole words</Options> 

<Color> the name of the highlight color, e.g., 
<Color>Turquoise</Color> 

Any characters in the <Text> field that have a special meaning in XML are 
replaced with their Hypertext Markup Language (HTML) codes: 

Character HTML Code 

> &gt; 

< &lt; 

& &amp; 

“ or ” &quot; 
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5.2. Where does Wordman’s Hiliter look for Keywords? 

Wordman’s Hiliter searches all possible areas of the Word document be-
ing examined. These areas are known as “story ranges.” There are poten-
tially 17 different story types in each Word document, and some story 
types can comprise multiple story ranges. For example, the Primary 
Header Story can contain multiple headers. 

Furthermore, ranges in some story types can contain other story ranges, 
e.g. a Header Story can contain a Text Frame Story, i.e. text in a text box. 
Wordman’s Hiliter checks the text in these stories as well. 

6. Disclaimer 

Every effort has been made to make this document as complete and as 
accurate as possible, but no warranty of fitness is implied. The 
information provided is on an “as is” basis. The author shall have neither 
liability nor responsibility to any person or entity with respect to any loss 
or damages arising from the information contained in this document. 

7. End User License Agreement 

All copyrights to Wordman’s Hiliter (“the software”) are exclusively owned 
by the author, Wordman Speaks. 

The software is only provided free for evaluation purposes. After the 
thirty-day evaluation period has expired, the user must purchase a license 
to continue using the software. A user is granted a non-exclusive right to 
use the software on one computer for any legal purpose. The software may 
not be rented or leased and may not be distributed without written permis-
sion of the copyright owner. 

The software is distributed “as is.” No warranty of any kind is expressed 
or implied. You use at your own risk. The author will not be liable for data 
loss, damages, loss of profits, or any other kind of loss while using or 
misusing this software. 

You may not use, copy, emulate, clone, rent, lease, sell, modify, decom-
pile, disassemble or otherwise reverse engineer the software, or any sub-
set of the software, except as provided for in this agreement. 

All rights not expressly granted here are reserved by Wordman Speaks. 
Installing and using the software signifies acceptance of these terms and 
conditions of the license. If you do not agree with the terms of this 
license, you must remove the software from your computer and cease to 
use the product. 


